Snowflake Chrome extension doesn't seem to be working for me

Hello folks,

I tried installing Snowflake Chrome extension to give it a try but it doesn’t seem to be working. I kept it enabled for hours, but all I can see is this:

Screenshot 2022-09-23 at 13.07.13

I haven’t seen any connections at all to it.

It doesn’t seem to be a problem related to my network, because I tried the same extension for Firefox and it seems to work:

I’ve also tried the embedded version (from Chrome!) and it seems to be working too:

What am I doing wrong? Thanks

1 Like

Sorry I can’t answer your question directly, but I was very surprised by numbers you showed.
With standalone proxy I have lot more connections in hour than your screenshot shows for a day:
2022/09/24 14:56:03 In the last 1h0m0s, there were 84 connections. Traffic Relayed ↑ 506 MB, ↓ 230 MB.
Do you have public IP address? If not, it may explain low connection count.

I have but it’s not mentioned anywhere I should have one. I assumed the proxy connects to some central node and gets traffic from other nodes.

A strange thing I notice (but I don’t know how to capture a video) is that when I click the extension icon the switch seems to move from disabled to enabled.

p.s: The numbers you see don’t cover a full day. I only kept it for a few minutes today and a 1 hour yesterday but the result was the same. I could see some connections on all the other methods but none from Chrome extension.

1 Like

The standalone is effectively ‘many’ snowflakes as it connects to multiple brokers so it will have more connections. One can run multiple tabs with a browser snowflake and get more connections that way. It’s safe to do.

···

On Sep 24, 2022, at 8:38 AM, Vort via Tor Project Forum <notifications_at_torproject1_discoursemail_com_7symmg8vsw4428_0a0598b2@icloud.com> wrote:

| Vort
September 24 |

  • | - |

Sorry I can’t answer your question directly, but I was very surprised by numbers you showed.
With standalone proxy I have lot more connections in hour than your screenshot shows for a day:
2022/09/24 14:56:03 In the last 1h0m0s, there were 84 connections. Traffic Relayed ↑ 506 MB, ↓ 230 MB.
Do you have public IP address? If not, it may explain low connection count.


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Hi @andreagrandi, do you have more add-ons installed and enabled? Maybe they are disabling your snowflake extension.

If I remember correctly, public IP can connect to public IP, private IP can connect to public IP, but private IP can’t connect to private IP, which means that private IP proxies are less useful and that’s why have less connections.

see here: https://forum.torproject.net/t/multiple-snowflake-proxies-behind-same-ip/4643/3

The standalone is effectively ‘many’ snowflakes as it connects to multiple brokers so it will have more connections. One can run multiple tabs with a browser snowflake and get more connections that way. It’s safe to do.

···

On Sep 24, 2022, at 8:44 AM, markcharn3ll@icloud.com wrote:

On Sep 24, 2022, at 8:38 AM, Vort via Tor Project Forum <notifications_at_torproject1_discoursemail_com_7symmg8vsw4428_0a0598b2@icloud.com> wrote:

| Vort
September 24 |

  • | - |

Sorry I can’t answer your question directly, but I was very surprised by numbers you showed.
With standalone proxy I have lot more connections in hour than your screenshot shows for a day:
2022/09/24 14:56:03 In the last 1h0m0s, there were 84 connections. Traffic Relayed ↑ 506 MB, ↓ 230 MB.
Do you have public IP address? If not, it may explain low connection count.


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Please explain it in more detail in my topic.
With my standalone proxy I see 1 connection to broker, N connections to single relay and N connections to different users.

I disabled them all except Snowflake and it didn’t make any difference.

Yes, I do have these installed and enabled:

Screenshot 2022-09-24 at 18.29.37

Thanks for the hint, I can maybe try disabling them one by one and see if it makes any difference.

I think this is a huge point. Snowflake volunteers need to be matched with Snowflake users (censored people) in a way where not both of them can be behind restricted NAT.

Many of the people in Iran right now are behind restricted NAT, so the snowflake volunteers that aren’t are way way way more useful.

Right, but what you seem to be missing from my explanation is that that using the same computer + the same Internet connection but using Firefox + Snowflake extension rather than Chrome + Snowflake, works. I’m aware I don’t see “many” connections with FF either, but at least I see 2-3 in a few minutes. With Chrome I always see zero.