New Release: Tor Browser 11.0

Thanks for reporting the broken link @flamingo! I’ve requested a redirect which should fix it in the short-term (once it’s set up), however I also encountered some extra weirdness that I’ve documented in Bug #40705 too.

Edit: The redirect seems to be working now thanks to some quick-acting from the SysAdmin team.

2 Likes

#40703 already has this reported. Just want to add a confirmation of the issue and ask how to downgrade to previous to version.

  • Operating System you are using
    Fedora 35

  • Tor Browser version
    11.0

  • Tor Browser Security Level
    After bug occured, I did a fresh install, so it should be default. Can’t look it up though.

  • Step by step of how you got to the issue, so we can reproduce it (e.g. I opened the browser, typed a url, clicked on (i) icon, then my browser crashed)
    First, updated to 11.0 from old install. Fonts are completely mangled. The did a fresh install to no avail.

  • (optional) A screenshot of the problem

  • The Tor log
    don’t know how and the state of the gui is not helping

It’s a know issue: Fonts don't render (#40671) · Issues · The Tor Project / Applications / Tor Browser · GitLab

1 Like

Same here: Fedora 33

The address bar is small, and it looks like the contents are off to one side:

I’m running OSX 11.6

Same over here:

Tor Browser 11 with xubuntu 20.04, Chinese showing in bookmarks, address bar, title in tab are incorrect.

Using English version of TBB has less problem, if you don’t surf websites in other language.

It looks like you’re experiencing this issue @Nate: Bug 40690. Does enabling “Always use private browsing mode” within general settings temporarily fix the UI?

Thanks for reporting @kekeno! Is this the issue you’re experiencing: Bug #40703? If so it’s a known issue, and you can follow our progress in that ticket.


post 1/2

These are the what i mean’t by the problems with ublock with v11.0

post 2/2

Thanks @hajj3, I’ve added those screenshots to the bug report :slight_smile:

I am on lubuntu18.04 x64. Tor browser 11.0 x64
I enter proxy settings and then exit Tor Browser. Start it again and proxy settings are gone.
So proxy settings are not saved, this is a bug.
Seems like they are lost when I close Settings tab.

I tried to set the Primary/Masterpassword but that did not work.
I ticket first the <> Ask to save logins and passwords for websites
Than clicked the primarypassword option.
the popup came up and showed no current pw, that is OK
I filled a pw, refilled same pw to confirm and clicked OK
an error message comes up: Unable to change Primary pw

Thanks for the bug report @ard! While the password manager is not officially supported in Tor Browser, I’ve opened this ticket to look into the issue further: Bug #40712

Hi @minacohen, do you have a Proxy Type selected in the dropdown menu?

on github matthew finkel wrote:

"One way of partially verifying this is the same bug as tor-browser-build#40383 (closed) is by:

  • Launch Tor Browser
  • Open about:addons or Addons and Themes from the hamburger menu
  • Disable only HTTPS Everywhere
  • Completely quit Tor Browser
  • Launch Tor Browser again
  • If the extensions are not broken anymore, then this bug is the same as tor-browser-build#40383 (closed) ( HTTPS Everywhere should still be disabled)"

I tried doing this but it didn’t help. I tried disabling and re-enabling ublock afterwards too and it didn’t help either.

Thanks for trying @hajj3! I’ve referred to your unsuccessful test in the ticket.

Haas anyone else had this? Tor Browser 11.0 for MacOS. Spacing at the top of the window is off. The address bar is too tall, so it overlaps the tabs…