New Release: Tor Browser 11.0

Tor Browser 11.0 is now available from the Tor Browser download page and our distribution directory. This is the first stable release based on Firefox ESR 91, and includes an important update to Tor 0.4.6.8.

Update: The version of Tor Browser for Windows available on the Tor Browser download page has been temporarily reverted to 10.5.10 while we investigate an issue with NoScript. Please see Bug 40695 for updates.

What’s new?

Tor Browser gets a new look

Earlier this year, Firefox’s user interface underwent a significant redesign aimed at simplifying the browser chrome, streamlining menus and featuring an all-new tab design. Firefox ESR 91 introduces the new design to Tor Browser for the first time.

To ensure it lives up to the new experience, each piece of custom UI in Tor Browser has been modernized to match Firefox’s new look and feel. That includes everything from updating the fundamentals like color, typography and buttons to redrawing each of our icons to match the new thinner icon style.

In addition to the browser chrome itself, the connection screen, circuit display, security levels and onion site errors all received a sprucing-up too – featuring some small but welcome quality of life improvements to each.

Final deprecation of v2 onion services

Last year we announced that v2 onion services would be deprecated in late 2021, and since its 10.5 release Tor Browser has been busy warning users who visit v2 onion sites of their upcoming retirement. At long last, that day has finally come. Since updating to Tor 0.4.6.8 v2 onion services are no longer reachable in Tor Browser, and users will receive an “Invalid Onion Site Address” error instead.

Should you receive this error when attempting to visit a previously working v2 address, there is nothing wrong with your browser – instead, the issue lies with the site itself. If you wish, you can notify the onion site’s administrator about the problem and encourage them to upgrade to a v3 onion service as soon as possible.

It’s easy to tell if you still have any old v2 addresses saved in your bookmarks that are in need of removal or updating too: although both end in .onion, the more secure v3 addresses are 56 characters long compared to v2’s modest 16 character length.

Known issues

Tor Browser 11.0 comes with a number of known issues:

  • Bug 40668: DocumentFreezer & file scheme
  • Bug 40671: Fonts don’t render
  • Bug 40679: Missing features on first-time launch in esr91 on MacOS
  • Bug 40689: Change Blockchair Search provider’s HTTP method
  • Bug 40667: AV1 videos shows as corrupt files in Windows 8.1
  • Bug 40677: Since the update to 11.0a9 some addons are inactive and need disabling-reenabling on each start
  • Bug 40666: Switching svg.disable affects NoScript settings
  • Bug 40690: Browser chrome breaks when private browsing mode is turned off
  • Bug 40693: Potential Wayland dependency (new)
  • Bug 40692: Picture-in-Picture is enabled on tbb 11.0a10 (new)
  • Bug 40700: Switch Firefox recommendations off by default (new)
  • Bug 40705: “visit our website” link on about:tbupdate pointing to different locations (new)
  • Bug 40706: Fix issue in https-e wasm (new)

Give feedback

If you find a bug or have a suggestion for how we could improve this release, please let us know. Thanks to all of the teams across Tor, and the many volunteers, who contributed to this release.

Full changelog

For the full changelog, please see our accompanying post on the Tor Project blog.

6 Likes

Awesome!

Should we download manually and replace it instead of auto update?

ublock origin isn’t working with tor browser v11.0.

For now 10.5.10 isn’t auto-updating to 11.0 which is good because for me (Fedora 34/35 and RHEL 8) 11.0 is unusable due to fonts rendering as square blocks. I observed this same problem on the a9 beta and it is also in the current a10 beta.

Fonts don't render (#40671) · Issues · The Tor Project / Applications / Tor Browser · GitLab is the problem I am seeing on all systems I’ve tried it on.

1 Like

It auto-updated for me. I’m on Linux Mint and Tor Browser is on 11.0a10.

how? mine doesn’t

It prompted me that a new version was available, so I updated, like usual.

That’s Alpha, not Stable 11.

1 Like

That’s right, I should have mentioned that, sorry

Did not Auto-Update for me - Tor 10.5.10 on Windows. :frowning:

(I did the download manually).

@xhdix @nixuser @Ephemeral @mylittlepony Apologies, I may have been a little quick to publish the release post! The auto-update started rolling out a few hours ago and should be available in your instance of Tor Browser soon – if it isn’t already.

2 Likes

Thanks @nixuser, we’re working on it!

Is this the issue you’re seeing @hajj3, or are you experiencing something different?

i don’t think so. Disabling and enabling doesn’t fix it. If i click on the addon on the address bar the box doesn’t display. If i try to go to the options for the addon the options don’t appear.

Changing Security Level to Safest DOES NOT disable javascript.

I’ve been using TB forever on gentoo linux amd64.
Autoupdated from 10.X. It won’t start because of some symbol missing in libxul.so.
My system is built with no wayland support, btw. The regular gentoo firefox-bin 91.3 runs fine.

$ ./tor-browser_en-US/Browser/start-tor-browser --verbose
XPCOMGlueLoad error for file /home/someuser/tor-browser_en-US/Browser/libxul.so:
/home/someuser/tor-browser_en-US/Browser/libxul.so: undefined symbol: gdk_wayland_display_get_wl_compositor
Couldn’t load XPCOM.
$

Hi @BugReporter19, thanks for the report. We’ve opened Bug #40693 for this and I’ve added it to our list of known issues in the blog post and OP too.

Hi @yoob, I’m not able to reproduce this unfortunately – how are you verifying that JavaScript is still enabled on Safest? Does a restart fix the issue at all?

I can reproduce this on Windows 10, newly downloaded TB 11 (but not Arch Linux). A simple DuckDuckGo search for test shows that JS is indeed not disabled, as DDG works like normal and I don’t get redirected to the HTML only version

1 Like

Thanks @HackerNCoder, I’m getting successfully redirected to the non-JavaScript site with a fresh install on MacOS. Are you running Windows as well @yoob?

Edit: I’ve opened an issue for this JS bug on Windows here – Bug #40695