How to setup port-forwading on router

I have spend so much time while setting up the ports, but couldn’t figure it out
in my router there is a WAN port range ___ ~ ___ and LAN port range ___ ~ ____
what should I put in WAN port range for configuring tor relay or bridge

Hello @1234e,

The port forwarding should be setup this way :

Internet :globe_with_meridians: → Your router on port 9001 :houses: → Your tor relay on port 9001 :onion:
WAN range would be 9001-9001 and LAN range would be 9001-9001
You can change the port 9001 to something else if you want.

If I understand your settings correctly, the range would allow only one port and it should works fine.

1 Like

hey thanks for the reply @Superpaul209 , I have been waiting for anyone to reply
I did setup port-forwarding as you said even before asking this question but didn’t resolve the problem I was getting, I getting this error “Relays do not publish descriptors until their ORPort and DirPort are reachable. Please check your firewalls, ports, address, /etc/hosts file, etc.”

and also I tell you one more error I was getting is that "port is already added for other service and is tor already started? " which I set the port randomly still I getting error so after I see the option called DMZ in my router and added that laptop in DMZ config box
and set ORPort as auto and still haven’t resolve it.

Please reply if you are free, I literally spend whole day to figure it out

Hello,

Can you give us more details about the issue please :

  • Which OS are you running ?
  • Do you setup a middle relay or a bridge ?
  • Do you have a firewall installed in your OS ?
  • Do you have other services running in your OS ? for example a web server, FTP or anything else
  • Could you share your torrc config please (remove your IP addresses)

For the DMZ setting, its not needed and not recommended because you are exposing your server to the Internet. Please disable it.

Thank you

usually internet provider dont let you open ports less 1 - 10000. i suggest you try high ports instead at your router.

Hello,
The issue has been fix, all I did set Address to my ddns address in torrc file, is okay? and yeah after that disabled DMZ and set port to 9001. I read on our tor forum someone said that to set external IP address

Its been more than one day,I have some question to ask

look at the logs
“[NOTICE] Since startup we initiated 0 and received 0 v1 connections; initiated 0 and received 0 v2 connections; initiated 0 and received 0 v3 connections; initiated 0 and received 28 v4 connections; initiated 468 and received 40236 v5 connections.”

  1. what is v1,v2,v3,v4,v5?
    2.since I am using ddns external ip, if the power goes off, after the router reboots it will handover the new Public IP so do I have to reboot my laptop?
  2. and how to setup ipv6 and DirPort tell that as well since I set DirPort to 9030 on metrics it shows 0 DirPort

Great ! The dynamic DNS is a good idea because a home router has a dynamic IP by default so its a good idea to keep it.

  1. The versions are about the addresses of Tor. The current version is 5.
  2. If your router reboots, you may need to restart your laptop. Some times I had the same problem and Tor doesn’t see the address change until you restart it.
  3. Since IPv6 isn’t dynamic like IPv4, you can get your address and set it manually in the torrc file like this :

ORPort [YourIPv6Address]:9001

The dirport is deprecated and not necessary to set, you can skip this step.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.

Thanks you so much @Superpaul209 for all your help. You are awesome bro

1 Like